О программе

Advanced Grapher 2.2, Copyright © 1998-2009 Alentum Software, Inc.

Advanced Grapher с интерфейсом на русском языке может использоваться в некоммерческих целях бесплатно.
Для коммерческого использования программу необходимо приобрести.

Вы можете скачать последнюю версию программы с ее домашней страницы: http://www.alentum.com/agrapher/.

Если у Вас есть вопросы или комментарии по поводу Advanced Grapher, Вы можете связаться с нами по e-mail agrapher@alentum.com.


История изменений

Версия 2.2:

  • Сохранение в формате GIF
  • Справка на русском языке

    Версия 2.11:

  • Исправлены несколько ошибок

    Версия 2.1:

  • Улучшения в интерфейсе
  • Поддержка до 100 графиков в одном документе
  • Исправлены несколько ошибок

    Версия 2.08:

  • Исправлены небольшие ошибки

    Версия 2.07:

  • Исправлены небольшие ошибки

    Версия 2.06:

  • Исправлены небольшие ошибки

    Версия 2.05:

  • Исправлена работа со свойствами графика по умолчанию
  • Улучшен интерфейс в «плоском» стиле

    Версия 2.03:

  • Улучшенный импорт таблиц
  • Поддерживает до 5000 точек на таблицу

    Версия 2.02:

  • Поддержка стилей Windows XP

    Версия 2.01:

  • Исправлены несколько ошибок

    Версия 2.0:

  • Интерфейс в стиле MS Office 2000
  • Улучшенное окно «Список графиков»
  • Новый калькулятор
  • Окно «Свойства документа»
  • Программа сохраняет все настройки в реестре (вместо INI-файла)
  • Новый формат файлов графиков (размер уменьшен в 2-20 раз в зависимости от файлов)
  • Небольшие улучшения в интерфейсе


Покупка

Advanced Grapher с интерфейсом на русском языке может использоваться в некоммерческих целях бесплатно.

Для коммерческого использования программу необходимо приобрести. Вы можете найти информацию о покупке программы на странице http://www.alentum.com/purchase.htm.


Как сделать...

Как...

...добавить новый график.

...удалить существующий график.

...улучшить точность графика.

...вставить график в документ Word.

...ввести таблицу значений. Добавьте новый график таблицы. После этого Вы можете ввести данные и построить график.

...сделать одинаковый масштаб по осям X и Y. Включите опцию «Одинаковый масштаб засечек» (страница «Оси» в окне «Свойства документа»).

...произвести трассировку графика. Щелкните кнопку [image] .

...пометить графики. Щелкните кнопку [image] . Затем щелкните на том месте на координатной плоскости, где нужно поместить метку. Для изменения свойств существующей метки два раза щелкните на ней левой кнопкой мыши или щелкните правой кнопкой мыши, а затем выберите команду «Свойства» вo всплывающем меню. Вы также можете удалить метку с помощью этого меню.

...произвести регрессионный анализ. Добавьте график таблицы, для которой нужно произвести анализ (если этот график еще не существует). Затем откройте окно «Регрессионный анализ» с помощью команды «Вычисления | Регрессионный анализ» из главного меню или кнопки на панели инструментов.

...использовать калькулятор. Введите любое выражение и нажмите Enter.

...построить график кусочной функции. Нужно добавить несколько графиков с разными уравнениями и интервалами построения.
Пример: Построим график кусочной функции y=cos(x) при x<=0; y=1 при 0<x<=1; y=x^2 при x>1. Видимый интервал [-10..10] для X и [-10..10] для Y.
1. Добавим график Y(x)=cos(x), установим для него опцию Минимум X в -10, Максимум X в 0.
2. Добавим график Y(x)=1, установим для него Минимум X в 0, Максимум X в 1.
3. Добавим график Y(x)=x^2, установим для него Минимум X в 1, Максимум X в 10.
В результате мы построим следующий график:

...построить график системы неравенств. Вам нужно использовать оператор AND. Например, если Вы хотите построит график системы sin(x)>xy; x^2<3y; y<4, Вам нужно построить график неравенства (sin(x)>xy and x^2<3y and y<4)>0.

...показать фон в списке графиков. Включите опцию «Показывать фон в списке графиков» (Правка | Параметры).


Глава 1. Выражения

Выражения в Advanced Grapher состоят из переменных, констант, чисел и функций от них, соединенных операторами.

Операторы

  • арифметические операторы: +, -, *, /, ^ (возведение в степень).
    Пример: 2+2^3=10
Совет: Вы можете использовать калькулятор для проверки примеров. Щелкните кнопку [image], чтобы показать калькулятор (рис. 1.1).

Рис. 1.1. Калькулятор

  • логические операторы. Результат и операнды принимают значения «истина» или «ложь».
    В программе не используются специальные значения для обозначения «истины» и «лжи». Если операнд меньше либо равен нулю, он воспринимается как «ложь», иначе как «истина». Результатом логических операций всегда является 0 («ложь») или 1 («истина»). Advanced Grapher позволяет использовать следующие логические операции: AND, OR, XOR и NOT. NOT – унарный оператор; AND, OR и XOR – бинарные. Результаты операций в зависимости от значений операндов представлены в следующей таблице:

    • Операнд 1 | Операнд 2 | AND | OR | XOR | NOT
0 | 0 | 0 | 0 | 0 | 1
0 | 1 | 0 | 1 | 1 |
1 | 0 | 0 | 1 | 1 | 0
1 | 1 | 1 | 1 | 0 |

    Результат операции NOT в таблице зависит только от значения первого (и единственного для данной операции) операнда.
    Примеры: 1 or 0=1; 5 and -1=0; (not 3) + 2*(1 xor 0)=2

  • операторы отношения: >,<,>=,<=,=,<>. Результат - 0 («ложь») или 1 («истина»). Эти операторы в основном используются для построения графиков систем неравенств.
    Примеры: (2>3) = 0; (3<=3) = 1; (0<>1) = 1

Функции

При использовании функций необходимо использовать синтаксис <Имя функции>(<Аргумент>).
Примеры: sin(x+2); ln(ln(1/x)); sin(x)^3.

Advanced Grapher поддерживает следующие функции:
sin - синус
cos - косинус
tan - тангенс
cot - котангенс
asin - арксинус
acos - арккосинус
atan - арктангенс
abs - модуль числа
sqrt - квадратный корень
ln - натуральный логарифм
lg - десятичный логарифм
exp - экспонента (exp(x) - e в степени x)
int - целая часть числа
round - округление
frac - дробная часть числа
sign - знак числа, sign(x)=1 при x>0, sign(x)=0 при x=0 и sign(x)=-1 при x<0
sinh - гиперболический синус
cosh - гиперболический косинус
tanh - гиперболический тангенс
coth - гиперболический котангенс
asinh - гиперболический арксинус
acosh - гиперболический арккосинус
atanh - гиперболический арктангенс
acoth - гиперболический арккотангенс
random - random(x)=rnd*x, rnd является случайным значением, 0<=rnd<1

Приоритет операций

1. Функции
2. ^
3. *,/
4. +,-
5. >=,=,<=,<,>,<>
6. not
7. and, or, xor
Функции имеют наивысший приоритет; and, or и xor – наименьший.
Пример: not 1+2 and 0 = (not (1+2)) and 0 = 0

Константы

В выражениях можно использовать константу Pi . Если Вы хотите использовать константу e (основание натурального логарифма), введите exp(1).

Переменные

Вы также можете использовать одну или две переменные, например, X, Y, A или T (в зависимости от ситуации).

Дополнительная информация

Можно пропускать знак умножения. Примеры: xy, (x+1)(5y+x), xx, xsin(x).


Глава 2. Управление графиками

Advanced Grapher имеет мощные средства для управления графиками. Вы можете легко создавать, удалять, дублировать графики, изменять их свойства и порядок в списке графиков.

Для управления графиками можно использовать панель инструментов «График» (рис. 2.1) и окно «Список графиков» (рис. 2.2 и 2.3). Щелкните кнопку [image], чтобы скрыть или показать список графиков.

Рис. 2.1. Панель инструментов «График»

Рис. 2.2. Список графиков

Рис. 2.3. Список графиков

Advanced Grapher позволяет производить следующие действия с графиками:

  • добавление нового графика. Для того, чтобы это сделать:
    1. Щелкните кнопку [image] или [image] на панели инструментов «График»; или
    2. Щелкните правой кнопкой мыши в окне «Список графиков» (но не на названии какого-либо графика) и выберите команду «Добавить график» или «Добавить график таблицы» из контекстного меню (рис. 2.3).
    Свойства графика будут установлены в свойства по умолчанию. При использовании команды «Добавить график таблицы» тип графика будет установлен в «Таблица». Вы можете изменить тип графика с помощью окна «Свойства графика».

Совет: если Вы прервали вычисление данных для графика и хотите его закончить, Вы можете использовать команду «Графики | Досчитать» из главного меню.

  • удаление существующего графика. Для того, чтобы это сделать:
    1. Выделите график (с помощью комбинированного списка на панели инструментов «График» или окна «Список графиков»). Затем щелкните кнопку [image] на панели инструментов «График»; или
    2. Щелкните правой кнопкой мыши на названии графика в окне «Список графиков» и выберите команду «Удалить график» из контекстного меню (рис. 2.2).
  • дублирование графика (создание графика с теми же свойствами, которые имеет уже существующий). Выделите график и щелкните кнопку [image] на панели инструментов «График».
  • изменение порядка графиков. Этот порядок определяет последовательность построения графиков. Для перемещения графика на другую позицию необходимо щелкнуть левой кнопкой мыши на его названии в списке графиков и, не отпуская кнопки, перетащить название в новое положение (рис. 2.4).

Рис. 2.4: Изменение порядка графиков

  • изменение свойств графика. Вы можете изменять различные свойства графика, включая параметры оформления, уравнение или таблицу, интервал построения и т.д.
    Некоторые параметры оформления, например, цвет и толщину линий, можно изменить без открытия дополнительных окон с использованием панели инструментов «График» (рис. 2.1).
    Для изменения других свойств используется окно «Свойства графика». Для вызова этого окна нужно:
    1. Щелкнуть кнопку [image] на панели инструментов «График»; или
    2. Дважды щелкнуть левой кнопкой мыши на названии графика в окне «Список графиков» или щелкнуть правой кнопкой мыши на названии графика и выбрать команду «Свойства» из контекстного меню.

Вы можете найти дополнительную информацию о свойствах графика в Главе 3.


Глава 3. Свойства графика

Графики имеют разнообразные свойства, некоторые из которых являются общими для разных типов графиков (например, описание и цвет), а наличие других зависит от типа. Каждый график имеет основные и дополнительные свойства.

Параметры оформления

Параметры оформления графика зависят от его типа. Например, графики неравенств не содержат линий, поэтому для них нельзя изменить стиль линий.

Самый простой способ изменить параметры оформления графика – это использовать панель инструментов «График» (рис. 3.1). Вы можете показывать и скрывать графики (кнопка [image]). Некоторые типы графиков (Y(x), X(y), графики таблиц и т.д.) могут быть построены линиями и/или точками, Вы можете изменять стиль штриховки для графиков неравенств и т.д.

Рис. 3.1: Панель инструментов «График»

Параметры оформления также можно изменить с помощью окна «Свойства графика». Это окно также показывается при добавлении или дублировании графика.

Рис. 3.2: Окно «Свойства графика»

Описание

Описание показывается в легенде, а также в списке графиков.

Y(x), X(y), R(a) - полярная система координат, X(t) и Y(t) - параметрические уравнения

Эти типы графиков очень похожи. Для каждого из них необходимо задать соответствующее уравнение.

Также можно задать интервал изменения независимой переменной (x, y, a или t). Если интервал для x или y не задан, он устанавливается равным видимому интервалу по соответствующей оси.

По умолчанию графики используют параметры построения, заданные в свойствах документа. Также имеется возможность настроить их для каждого конкретного графика.

Рис. 3.3: Параметры построения не заданы

Рис. 3.4: Параметры построения заданы

Количество шагов определяет точность построения. Точность построения увеличивается при увеличении количества шагов. В некоторых случаях бывает полезно задать маленькое количество шагов, например, когда график строится с изображением точек (рис. 3.5). Количество точек в графике равно количеству шагов плюс 1.

Рис. 3.5: График, количество шагов – 8, количество точек – 9

Совет: если Вы не задавали параметры построения для некоторых графиков, Вы можете изменить их для этих графиков (например, чтобы увеличить точность) с помощью окна «Свойства документа».

Максимальный разрыв – более сложный параметр. Это число, измеряемое в процентах от интервала. Если расстояние между двумя соседними точками больше максимального разрыва, точки не соединяются линиями. Advanced Grapher вычисляет разрыв по осям X и Y независимо. Затем он вычисляет величины РазрывX/ИнтервалX и РазрывY/ИнтервалY. Если хотя бы одно из этих значений больше максимального разрыва (например, 200%=2), точки не соединяются линией.

Небольшое значение максимального разрыва бывает необходимо использовать при построении графиков с разрывами, например, int(x) или tan(x).

F(x,y)>|=|<0 - уравнение или неравенство

Для этих графиков также можно задавать количество шагов, максимальный разрыв (для уравнений) и интервалы.

dy/dx или dx/dy - поле направлений

Можно задавать интервалы, количество рядов по горизонтали и вертикали, длину линий.

Таблица

Программа имеет расширенные возможности для работы с таблицами (рис. 3.6).

Рис. 3.6: Средства для работы с таблицами

Совет: с помощью команд «Вырезать», «Копировать» и «Вставка» можно обмениваться информацией с другими программами, работающими с таблицами, например, с Microsoft Excel. Кроме того, используя команды главного меню «Файл | Импорт таблицы» и «Файл | Экспорт таблицы» можно импортировать и экспортировать табличные данные в текстовые файлы. Вы можете также отменять до 15 последних операций с таблицей.

Вы также можете определять дополнительный свойства графиков таблиц: тип сортировки и сглаживание (с помощью кубических сплайнов).

Свойства графика по умолчанию

При добавлении нового графика его свойства устанавливаются в значения по умолчанию. При изменении типа графика (в окне «Свойства графика») его дополнительные свойства также устанавливаются в значения по умолчанию. Вы можете изменить свойства графика по умолчанию с помощью окна «Свойства графика по умолчанию» (рис. 3.7). Это окно может быть вызвано с помощью команды «Графики | Свойства графика по умолчанию» из главного меню.

Рис. 3.7: Окно «Свойства графика по умолчанию»

Совет: при включенной опции «Новый цвет для нового графика» («Правка | Параметры») программа при добавлении графика автоматически устанавливает его цвет таким образом, чтобы он совпадал с цветом наименьшего числа других графиков.


Глава 4. Свойства документа

Параметры документа определяют отображение координатной плоскости, интервалы построения и параметры построения графиков. Изменить параметры документа можно с помощью окна «Свойства документа» (рис. 4.1). Его можно вызвать с помощью кнопки [image] или команды «Графики | Свойства документа» в главном меню.

Рис. 4.1. Окно «Свойства документа»

Параметры построения

Эти настройки могут быть определены с помощью страницы «Построение».

  • Интервалы. Интервалы можно менять как с помощью окна «Свойства документа», так и с помощью кнопок, расположенных на панели инструментов «Стандартная» (рис. 4.2).
    Первые 10 кнопок предназначены для увеличения и уменьшения интервалов по осям X и Y, а также для смещения интервалов влево/вправо/вверх/вниз.
    Кнопка [image] используется для выбора интервала. Щелкните ее, затем щелкните левой кнопкой мыши на координатной плоскости и переместите курсор мыши для выделения нужного интервала.
    Кнопка [image] перемещает начало координат в центр активного окна.

Рис 4.2. Панель инструментов «Стандартная»

Совет: при изменении интервалов с помощью панели инструментов «Стандартная» шаги меток и засечек меняются автоматически. При изменении интервалов с помощью окна «Свойства документа» шаги меток и засечек меняются в том случае, если установлена опция «Изменять шаги при изменении интервалов» («Правка | Параметры»).

  • Параметры построения. Опции «Количество шагов» и «Максимальный разрыв» используются как соответствующие свойства графиков по умолчанию (см. главу 3).
    Опция «Выравнивание точек» может быть полезна в некоторых специальных случаях. Если эта опция включена, аргументы X, Y, A или T будут принимать значения, равные K * Интервал_Точек, где Интервал_Точек равен соответствующему интервалу, поделенному на количество шагов. Таким образом, в некоторых случаях количество построенных точек будет равно количеству шагов (вместо количества шагов плюс 1). Если же опция выключена, значения функций всегда будут вычислены для значений параметров, соответствующих границам интервала. Однако в этом случае, если интервал содержит 0, есть вероятность, что функция не будет вычислена для значения параметра, равного 0.
    Данная опция обычно бывает полезна при небольшом количестве шагов.
    Пример: график функции Y(x)=x^2, количество шагов равно 7 (рис. 4.3 и 4.4).

Рис. 4.3. Выравнивание точек включено

Рис. 4.4. Выравнивание точек выключено

  • Коэффициенты. Реальные значения по осям равны видимым значениям, умноженным на коэффициенты по соответствующим осям. При определении интервалов в этом окне или в дополнительных свойствах графиков используются «видимые» значения, которые затем умножаются на коэффициент. В таблице значений при этом указываются реальные значения, которые при отображении делятся на указанный коэффициент. Например, если координата Y точки в таблице равна 6 и коэффициент по оси Y равен 2, то координата точки на экране равна 6/2 = 3.
    Коэффициенты могут быть использованы, например, при построении графиков тригонометрических функций. Если строится график функций вида Y(x), коэффициент по оси X может быть установлен в значение 3.1415927. В этом случае координаты по оси X будут измеряться в долях Пи. Для автоматической установки подобных свойств можно также использовать команду меню «Графики | Наборы свойств | Тригонометрический набор».
  • Логарифмическая шкала. Для использования логарифмической шкалы отметьте соответствующие опции («Ось X» и/или «Ось Y»). Вы также можете указать основания логарифмов. При включенной логарифмической шкале все интервалы представляются в формате основание^число. При задании интервала по X в -2..2, основания логарифма по X в 10 и включении логарифмической шкалы по X реальный интервал будет 10^-2..10^2.

Легенда

Легенда может быть полезна при печати графиков и подготовке иллюстраций.

В легенде показывается описание графика. Если же оно не задано, то показывается соответствующая формула или количество точек (для графиков таблиц). Вы можете изменять описание графика с помощью окна «Свойства графика» (см. главу 3).

Совет: описание также показывается в списке графиков. Например, «Y(x)=2.5/x [Изотерма]», «Изотерма» это описание графика.

Пример: Рис. 4.5. Для графика уравнения задано описание «Эллипс». При этом для графика неравенства описание не задано, поэтому в легенде показывается его формула.

Рис. 4.5. График с легендой

Вы можете изменить настройки легенды на странице «Легенда». Включить и выключить легенду можно также с помощью меню, которое появляется при щелчке правой кнопкой мыши в окне документа (рис. 4.6).

Рис. 4.6: Меню изменения параметров документа


Глава 5. Вычислительные возможности

Работа с вычислительными возможностями осуществляется с помощью панели инструментов «Вычисления» или меню «Вычисления» (рис. 5.1).

Рис. 5.1. Меню «Вычисления»

Вы можете получить дополнительную информацию об окнах «Исследование функции», «Пересечения» и «Регрессионный анализ».


Глава 6. Файлы и буфер обмена

Файлы

Вы можете открывать и сохранять документы с помощью меню «Файл», а также кнопок [image] и [image] на панели инструментов.

Экспорт и импорт данных

Advanced Grapher позволяет импортировать и экспортировать информацию в другие программы и файлы.

  • Экспорт изображений графиков. Графики (изображения координатной плоскости) можно сохранять в файлы в форматах GIF, BMP и EMF, а также копировать в буфер обмена в форматах EMF и BMP. Формат EMF является векторным, поэтому он является предпочтительным для обмена с теми программами, которые в дальнейшем будут масштабировать рисунок (например, Microsoft Word). Для сохранения и копирования рисунка используются соответственно команды «Файл | Сохранить как рисунок» и «Правка | Копировать как рисунок».
    При экспорте рисунка можно указать масштаб. Это бывает полезно, если, например, нужно будет печатать рисунок из других программ после импорта в них из Advanced Grapher.
  • Импорт и экспорт табличных данных. Осуществляется с помощью команд «Файл | Импорт таблицы» и «Файл | Экспорт таблицы». Также при редактировании таблицы можно обмениваться данными с другими программами с использованием буфера обмена (см. главу 3).

Печать документов осуществляется с помощью команды «Файл | Печать» или кнопки [image] на панели инструментов.


Исследование функции

Данное окно предназначено для указания параметров исследования функции.

Вы можете ввести формулу функции или выбрать ее в комбинированном списке «Y(x)». Этот список содержит формулы функций типа Y(x), чьи графики существуют в активном документе. Выберите опцию «Нули функции» и/или «Экстремумы», если Вы хотите найти нули/экстремумы функции.

Вы можете выбрать интервал, на котором функция будет анализироваться, с помощью настроек «Минимум X» и «Максимум X». Введенные значения абсолютные, они не зависят от коэффициента по X (см. Параметры построения).

Если Вы выбрали опцию «Использовать производную», то при нахождении экстремумов будет использована аналитически найденная производная.

Примечание: программа не всегда может найти нули и экстремумы функции с точностью, указанной в поле ввода «Точность (десят. знаков)».


Пересечения

Данное окно предназначено для указания параметров нахождения координат точек пересечения графиков функций.

Вы можете ввести формулы функций или выбрать их в комбинированных списках «Y1(x)» и «Y2(x)». Эти списки содержит формулы функций типа Y(x), чьи графики существуют в активном документе.

Вы можете выбрать интервал, на котором будут находиться пересечения, с помощью настроек «Минимум X» и «Максимум X». Введенные значения абсолютные, они не зависят от коэффициента по X (см. Параметры построения).


Параметры

Вы можете использовать данное окно для изменения параметров интерфейса программы. Окно содержит следующие элементы:

Подтверждения | Удалить график. Опция контролирует показ подтверждения при удалении графика.

Новый цвет для нового графика. Если эта настройка отключена, то при добавлении нового графика его цвет определяется свойствами по умолчанию. Если же настройка включена, то при добавлении графика программа автоматически выбирает цвет, используемый наименьшим числом существующих графиков и отличный от цвета фона.

Изменять шаги при изменении интервалов. Если эта опция включена, то при изменении интервалов в окне «Свойства документа» пропорционально изменяются также шаги сетки, засечек и меток.

Показывать фон в списке графиков. Эта опция может быть полезной, например, если цвет фона черный, цвет некоторых графиков белый и цвет списка графиков также белый.

Показывать окно заставки. Показывать окно заставки при запуске программы.


Регрессионный анализ

Данное окно может быть использовано для нахождения функции Y(x), наилучшим образом описывающей заданную таблицу значений X и Y. Регрессионный анализ производится с помощью метода наименьших квадратов. Окно содержит следующие элементы:

Таблицы. Комбинированный список предназначен для выбора таблицы, для которой будет производиться регрессионный анализ.

Тип регрессии. Для полиномиальной регрессии также можно выбрать степень полинома. При выборе типа регрессии «Лучшая» происходит автоматический выбор регрессии с наибольшим значением коэффициента детерминации R^2.

Соответствие. Эта группа элементов показывает значения стандартного отклонения и коэффициента детерминации R^2.
Если функция не может быть найдена, программа показывает дополнительную информацию об этом. Функция не может быть найдена, если количество точек с разными абсциссами меньше 2 или если таблица содержит данные, не подходящие для данного типа регрессии (для гиперболической регрессии X не должен быть равен нулю, для логарифмической – X должен быть больше нуля, для степенной – X > 0 и Y > 0, для экспоненциальной и показательной – Y < 0).

Y(x). Поле содержит формулу найденной функции.

Добавить график. Добавить график найденной функции.